Update your MT4 till the 1st of July

Thu, 13 Jun 2019 16:14

Dear traders,

Please note that Support for MetaTrader 4 client terminal versions below 1170 will be discontinued on the 1st of July 2019.

If you use MetaTrader 4 ver. 1170, the update function is automatically adjusted, if not cancelled manually.

Unsupported terminal builds will not be able to connect to new server versions.

We strongly recommend to update your terminals in advance.

Kind regards,

MTrading Team